re = /^```(?:\w+)?\s*\n(.*?)(?=^```)```/m
str = 'Lorem ipsum
```python
print(\'foo```bar```foo\')
print(\'foo```bar```foo\')
```
Lorem ipsum
```python
print(\'foo```bar```foo\')
print(\'foo```bar```foo\')
```
Lorem ipsum
```
print(\'foo```bar```foo\')
print(\'foo```bar```foo\')
```
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end