$re = '/^```(?:\w+)?\s*\n(.*?)(?=^```)```/ms';
$str = 'Lorem ipsum
```python
print(\'foo```bar```foo\')
print(\'foo```bar```foo\')
```
Lorem ipsum
```python
print(\'foo```bar```foo\')
print(\'foo```bar```foo\')
```
Lorem ipsum
```
print(\'foo```bar```foo\')
print(\'foo```bar```foo\')
```
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);