import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^```(?:\\w+)?\\s*\\n(.*?)(?=^```)```";
final String string = "Lorem ipsum\n"
+ "```python\n"
+ "print('foo```bar```foo')\n"
+ "print('foo```bar```foo')\n"
+ "```\n"
+ "Lorem ipsum\n"
+ "```python\n"
+ "print('foo```bar```foo')\n"
+ "print('foo```bar```foo')\n"
+ "```\n"
+ "Lorem ipsum\n"
+ "```\n"
+ "print('foo```bar```foo')\n"
+ "print('foo```bar```foo')\n"
+ "```\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}