using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^```(?:\w+)?\s*\n(.*?)(?=^```)```";
string input = @"Lorem ipsum
```python
print('foo```bar```foo')
print('foo```bar```foo')
```
Lorem ipsum
```python
print('foo```bar```foo')
print('foo```bar```foo')
```
Lorem ipsum
```
print('foo```bar```foo')
print('foo```bar```foo')
```
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}