using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?<!\S).(?!\S)";
string substitution = @" ";
string input = @"I am testing regex. This'll print results for A B c d ^ * ( ) { } [ ] done .";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}