import Foundation
let pattern = #"(?s)(?<!\S).(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I am testing regex. This'll print results for A B c d ^ * ( ) { } [ ] done ."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)