use strict;
my $str = 'I am testing regex. This\'ll print results for A B c d ^ * ( ) { } [ ] done .';
my $regex = qr/(?s)(?<!\S).(?!\S)/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";