const regex = /(?s)(?<!\S).(?!\S)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)(?<!\\S).(?!\\S)', 'g')
const str = `I am testing regex. This'll print results for A B c d ^ * ( ) { } [ ] done .`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);