import re
regex = re.compile(r"(?s)(?<!\S).(?!\S)")
test_str = "I am testing regex. This'll print results for A B c d ^ * ( ) { } [ ] done ."
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)