$re = '/(?s)(?<!\S).(?!\S)/';
$str = 'I am testing regex. This\'ll print results for A B c d ^ * ( ) { } [ ] done .';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;