# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^|[^-+.()\w])(hello)(?![-+.()\w])/$1$2/gm;t' <<< "hello
+hello
-hello
hello+
ahello
helloa
&hello
hello%
"