use strict;
my $str = 'hello
+hello
-hello
hello+
ahello
helloa
&hello
hello%
';
my $regex = qr/(?:^|[^-+.()\w])(hello)(?![-+.()\w])/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";