import Foundation
let pattern = #"(?:^|[^-+.()\w])(hello)(?![-+.()\w])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
hello
+hello
-hello
hello+
ahello
helloa
&hello
hello%
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)