#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^|[^-+.()\w])(hello)(?![-+.()\w])"
Local $sString = "hello" & @CRLF & _
"+hello" & @CRLF & _
"-hello" & @CRLF & _
"hello+" & @CRLF & _
"ahello" & @CRLF & _
"helloa" & @CRLF & _
"&hello" & @CRLF & _
"hello%" & @CRLF & _
""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)