re = /(?:^|[^-+.()\w])(hello)(?![-+.()\w])/m
str = 'hello
+hello
-hello
hello+
ahello
helloa
&hello
hello%
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result