import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/)(0-9)(\\/j\\/)";
final String string = "<div>... <span class=\"highlight highlight--wrapping\">Chuck</span> <span class=\"highlight highlight--wrapping\">Feeney</span> (David Cantwell for Forbes) \n\n"
+ "On a cool summer afternoon at Dublin's Heuston Station, <span class=\"highlight highlight--wrapping\">Chuck</span> <span class=\"highlight highlight--wrapping\">Feeney</span>, 81...<br> slowly limped out of the station completely unnoticed. And that's just how <span class=\"highlight highlight--wrapping\">Feeney</span> likes it.\n"
+ "<span class=\"highlight highlight--wrapping\">Chuck</span> <span class=\"highlight highlight--wrapping\">Feeney</span> is the James ...</div>\n\n\n"
+ "https://www.procaretherapy.com/school-jobs/contracted-early-intervention-school-psychologist-job-near-king-of-prussia-pa/1327725/j/#apply";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}