import Foundation
let pattern = #"(\/)(0-9)(\/j\/)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
<div>... <span class="highlight highlight--wrapping">Chuck</span> <span class="highlight highlight--wrapping">Feeney</span> (David Cantwell for Forbes)
On a cool summer afternoon at Dublin's Heuston Station, <span class="highlight highlight--wrapping">Chuck</span> <span class="highlight highlight--wrapping">Feeney</span>, 81...<br> slowly limped out of the station completely unnoticed. And that's just how <span class="highlight highlight--wrapping">Feeney</span> likes it.
<span class="highlight highlight--wrapping">Chuck</span> <span class="highlight highlight--wrapping">Feeney</span> is the James ...</div>
https://www.procaretherapy.com/school-jobs/contracted-early-intervention-school-psychologist-job-near-king-of-prussia-pa/1327725/j/#apply
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)