const regex = /(\/)(0-9)(\/j\/)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/)(0-9)(\\\/j\\\/)', 'gmi')
const str = `<div>... <span class="highlight highlight--wrapping">Chuck</span> <span class="highlight highlight--wrapping">Feeney</span> (David Cantwell for Forbes)
On a cool summer afternoon at Dublin's Heuston Station, <span class="highlight highlight--wrapping">Chuck</span> <span class="highlight highlight--wrapping">Feeney</span>, 81...<br> slowly limped out of the station completely unnoticed. And that's just how <span class="highlight highlight--wrapping">Feeney</span> likes it.
<span class="highlight highlight--wrapping">Chuck</span> <span class="highlight highlight--wrapping">Feeney</span> is the James ...</div>
https://www.procaretherapy.com/school-jobs/contracted-early-intervention-school-psychologist-job-near-king-of-prussia-pa/1327725/j/#apply`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}