// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(\/)(0-9)(\/j\/)").unwrap();
let string = "<div>... <span class=\"highlight highlight--wrapping\">Chuck</span> <span class=\"highlight highlight--wrapping\">Feeney</span> (David Cantwell for Forbes)
On a cool summer afternoon at Dublin's Heuston Station, <span class=\"highlight highlight--wrapping\">Chuck</span> <span class=\"highlight highlight--wrapping\">Feeney</span>, 81...<br> slowly limped out of the station completely unnoticed. And that's just how <span class=\"highlight highlight--wrapping\">Feeney</span> likes it.
<span class=\"highlight highlight--wrapping\">Chuck</span> <span class=\"highlight highlight--wrapping\">Feeney</span> is the James ...</div>
https://www.procaretherapy.com/school-jobs/contracted-early-intervention-school-psychologist-job-near-king-of-prussia-pa/1327725/j/#apply";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}