#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?'box_string'T(?'mod_id'[0-9]{4})(?'box_num'[0-9]{1,}))(?'comma_qty',(?'qty'[0-9]{1,}))?$"
Local $sString = "T0123456" & @CRLF & _
"T0123456,12" & @CRLF & _
"T0123456," & @CRLF & _
"T012345a6" & @CRLF & _
"T0123456,0t" & @CRLF & _
"0T0123456" & @CRLF & _
"0T0123456,1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")