$re = '/^(?\'box_string\'T(?\'mod_id\'[0-9]{4})(?\'box_num\'[0-9]{1,}))(?\'comma_qty\',(?\'qty\'[0-9]{1,}))?$/m';
$str = 'T0123456
T0123456,12
T0123456,
T012345a6
T0123456,0t
0T0123456
0T0123456,1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);