using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?'box_string'T(?'mod_id'[0-9]{4})(?'box_num'[0-9]{1,}))(?'comma_qty',(?'qty'[0-9]{1,}))?$";
string input = @"T0123456
T0123456,12
T0123456,
T012345a6
T0123456,0t
0T0123456
0T0123456,1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}