// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?'box_string'T(?'mod_id'[0-9]{4})(?'box_num'[0-9]{1,}))(?'comma_qty',(?'qty'[0-9]{1,}))?$").unwrap();
let string = "T0123456
T0123456,12
T0123456,
T012345a6
T0123456,0t
0T0123456
0T0123456,1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}