use strict;
my $str = 'T0123456
T0123456,12
T0123456,
T012345a6
T0123456,0t
0T0123456
0T0123456,1';
my $regex = qr/^(?'box_string'T(?'mod_id'[0-9]{4})(?'box_num'[0-9]{1,}))(?'comma_qty',(?'qty'[0-9]{1,}))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}