const regex = /^(?'box_string'T(?'mod_id'[0-9]{4})(?'box_num'[0-9]{1,}))(?'comma_qty',(?'qty'[0-9]{1,}))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?\'box_string\'T(?\'mod_id\'[0-9]{4})(?\'box_num\'[0-9]{1,}))(?\'comma_qty\',(?\'qty\'[0-9]{1,}))?$', 'gm')
const str = `T0123456
T0123456,12
T0123456,
T012345a6
T0123456,0t
0T0123456
0T0123456,1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}