using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{3}(?<=\b\d{10}\b)|(?=\b\d{15}\b)\d{3}";
string input = @"8788467490
2093247823403
1284092048
739432387779983
91019283839
830082763683651
982188727212";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}