re = /\d{3}(?<=\b\d{10}\b)|(?=\b\d{15}\b)\d{3}/m
str = '8788467490
2093247823403
1284092048
739432387779983
91019283839
830082763683651
982188727212'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end