const regex = new RegExp('\\d{3}(?<=\\b\\d{10}\\b)|(?=\\b\\d{15}\\b)\\d{3}', 'gm')
const str = `8788467490
2093247823403
1284092048
739432387779983
91019283839
830082763683651
982188727212`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}