$re = '/\d{3}(?<=\b\d{10}\b)|(?=\b\d{15}\b)\d{3}/m';
$str = '8788467490
2093247823403
1284092048
739432387779983
91019283839
830082763683651
982188727212';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);