use strict;
my $str = '8788467490
2093247823403
1284092048
739432387779983
91019283839
830082763683651
982188727212';
my $regex = qr/\d{3}(?<=\b\d{10}\b)|(?=\b\d{15}\b)\d{3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}