import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{3}(?<=\\b\\d{10}\\b)|(?=\\b\\d{15}\\b)\\d{3}";
final String string = "8788467490\n"
+ "2093247823403\n"
+ "1284092048\n"
+ "739432387779983\n"
+ "91019283839\n"
+ "830082763683651\n"
+ "982188727212";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}