using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"class=""txt-color-[a-z]+""";
string input = @"class=""txt-color-red""
class=""txt-color-black""
class=""txt-color-green""
class=""txt-color-blue""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}