import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "class=\"txt-color-[a-z]+\"";
final String string = "class=\"txt-color-red\" \n"
+ "class=\"txt-color-black\"\n"
+ "class=\"txt-color-green\"\n"
+ "class=\"txt-color-blue\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}