$re = '/class="txt-color-[a-z]+"/m';
$str = 'class="txt-color-red"
class="txt-color-black"
class="txt-color-green"
class="txt-color-blue"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);