re = /class="txt-color-[a-z]+"/m
str = 'class="txt-color-red"
class="txt-color-black"
class="txt-color-green"
class="txt-color-blue"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end