// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)class="txt-color-[a-z]+""#).unwrap();
let string = "class=\"txt-color-red\"
class=\"txt-color-black\"
class=\"txt-color-green\"
class=\"txt-color-blue\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}