package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)class="txt-color-[a-z]+"`)
var str = `class="txt-color-red"
class="txt-color-black"
class="txt-color-green"
class="txt-color-blue"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}