#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![_ -])(?:(?![_ -]{2})[\w -]){5,16}(?<![_ -])$"
Local $sString = "** VALID **" & @CRLF & _
"usern" & @CRLF & _
"username-is-writ" & @CRLF & _
"username is here" & @CRLF & _
"username_is_here" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"** INVALID **" & @CRLF & _
"user" & @CRLF & _
"username-is-written-here" & @CRLF & _
"-username" & @CRLF & _
"_username" & @CRLF & _
" username" & @CRLF & _
"username-" & @CRLF & _
"username_" & @CRLF & _
"username " & @CRLF & _
"username--here" & @CRLF & _
"username here" & @CRLF & _
"username__here" & @CRLF & _
"username- here" & @CRLF & _
"username _here"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")