const regex = /^(?![_ -])(?:(?![_ -]{2})[\w -]){5,16}(?<![_ -])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![_ -])(?:(?![_ -]{2})[\\w -]){5,16}(?<![_ -])$', 'gm')
const str = `** VALID **
usern
username-is-writ
username is here
username_is_here
** INVALID **
user
username-is-written-here
-username
_username
username
username-
username_
username
username--here
username here
username__here
username- here
username _here`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}