use strict;
my $str = '** VALID **
usern
username-is-writ
username is here
username_is_here
** INVALID **
user
username-is-written-here
-username
_username
username
username-
username_
username
username--here
username here
username__here
username- here
username _here';
my $regex = qr/^(?![_ -])(?:(?![_ -]{2})[\w -]){5,16}(?<![_ -])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}