import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![_ -])(?:(?![_ -]{2})[\\w -]){5,16}(?<![_ -])$";
final String string = "** VALID **\n"
+ "usern\n"
+ "username-is-writ\n"
+ "username is here\n"
+ "username_is_here\n\n\n"
+ "** INVALID **\n"
+ "user\n"
+ "username-is-written-here\n"
+ "-username\n"
+ "_username\n"
+ " username\n"
+ "username-\n"
+ "username_\n"
+ "username \n"
+ "username--here\n"
+ "username here\n"
+ "username__here\n"
+ "username- here\n"
+ "username _here";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}