# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?![_ -])(?:(?![_ -]{2})[\w -]){5,16}(?<![_ -])$"
test_str = ("** VALID **\n"
"usern\n"
"username-is-writ\n"
"username is here\n"
"username_is_here\n\n\n"
"** INVALID **\n"
"user\n"
"username-is-written-here\n"
"-username\n"
"_username\n"
" username\n"
"username-\n"
"username_\n"
"username \n"
"username--here\n"
"username here\n"
"username__here\n"
"username- here\n"
"username _here")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.