package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)# Horizontal grid.
(?<=\|\s|\|\s:)(-+)(?=:?\s\|)
|
# Vertical grid.
((?<=\|\s):|:(?=\s\|))
|
# Header colon.
((?<=^)\|(?=\s)|(?<=\s)\|(?=$)|\|(?=\s+.+\s+\|))`)
var str = `# Time block
| Time | Block |
| ----------: | :---------------- |
| (00:00) | (Revision #1) |
| | |
| 00:00-00:00 | Chunk |
| | - Note w/ details |
| 00:00-00:00 | Some meeting |
| 11:00-13:00 | Chunk |
| | - Note w/ details |
| | |
| (00:00) | (Revision #1) |
| 00:00-00:00 | Chunk |
| | - Note w/ details |
# Todo
| Tracker | Task | Backlog |
| ----------: | :------------- | :------------ |
| 00:00-00:00 | [x] Task one | [[wiki.link |
| 00:00-00:00 | | |
| 0m | | |
| | | |
| | [<] Task two | [[wiki.link]] |
| | [<] Task three | [[wiki.link]] |
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}