import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# Horizontal grid.\n"
+ "(?<=\\|\\s|\\|\\s:)(-+)(?=:?\\s\\|)\n"
+ "|\n\n"
+ "# Vertical grid.\n"
+ "((?<=\\|\\s):|:(?=\\s\\|))\n"
+ "|\n\n"
+ "# Header colon.\n"
+ "((?<=^)\\|(?=\\s)|(?<=\\s)\\|(?=$)|\\|(?=\\s+.+\\s+\\|))";
final String string = "# Time block\n\n"
+ "| Time | Block |\n"
+ "| ----------: | :---------------- |\n"
+ "| (00:00) | (Revision #1) |\n"
+ "| | |\n"
+ "| 00:00-00:00 | Chunk |\n"
+ "| | - Note w/ details |\n"
+ "| 00:00-00:00 | Some meeting |\n"
+ "| 11:00-13:00 | Chunk |\n"
+ "| | - Note w/ details |\n"
+ "| | |\n"
+ "| (00:00) | (Revision #1) |\n"
+ "| 00:00-00:00 | Chunk |\n"
+ "| | - Note w/ details |\n\n"
+ "# Todo \n\n"
+ "| Tracker | Task | Backlog |\n"
+ "| ----------: | :------------- | :------------ |\n"
+ "| 00:00-00:00 | [x] Task one | [[wiki.link |\n"
+ "| 00:00-00:00 | | |\n"
+ "| 0m | | |\n"
+ "| | | |\n"
+ "| | [<] Task two | [[wiki.link]] |\n"
+ "| | [<] Task three | [[wiki.link]] |\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}