// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)# Horizontal grid.
(?<=\|\s|\|\s:)(-+)(?=:?\s\|)
|
# Vertical grid.
((?<=\|\s):|:(?=\s\|))
|
# Header colon.
((?<=^)\|(?=\s)|(?<=\s)\|(?=$)|\|(?=\s+.+\s+\|))").unwrap();
let string = "# Time block
| Time | Block |
| ----------: | :---------------- |
| (00:00) | (Revision #1) |
| | |
| 00:00-00:00 | Chunk |
| | - Note w/ details |
| 00:00-00:00 | Some meeting |
| 11:00-13:00 | Chunk |
| | - Note w/ details |
| | |
| (00:00) | (Revision #1) |
| 00:00-00:00 | Chunk |
| | - Note w/ details |
# Todo
| Tracker | Task | Backlog |
| ----------: | :------------- | :------------ |
| 00:00-00:00 | [x] Task one | [[wiki.link |
| 00:00-00:00 | | |
| 0m | | |
| | | |
| | [<] Task two | [[wiki.link]] |
| | [<] Task three | [[wiki.link]] |
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}