using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\*([a-zA-Z ]+)\*";
string substitution = @"<b>$1</b>";
string input = @"What kind of *vegetable* is it?
I hope I am not late.
All *the good* shows are *no longer* broadcasting.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}