re = /\*([a-zA-Z ]+)\*/
str = 'What kind of *vegetable* is it?
I hope I am not late.
All *the good* shows are *no longer* broadcasting.'
subst = '<b>$1</b>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result