use strict;
my $str = 'What kind of *vegetable* is it?
I hope I am not late.
All *the good* shows are *no longer* broadcasting.';
my $regex = qr/\*([a-zA-Z ]+)\*/p;
my $subst = '<b>$1</b>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";