$re = '/\*([a-zA-Z ]+)\*/';
$str = 'What kind of *vegetable* is it?
I hope I am not late.
All *the good* shows are *no longer* broadcasting.';
$subst = "<b>$1</b>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;