# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^source\.(.+)$/EXTERNAL_\U$1\E/gm;t' <<< "source.organizations
source.departments
source.employees"